Людочка13
22.05.2022 15:32

Дана матрица 5*5 сформированная случайным образом. Написать программу, которая выводит на экран произведение всех нечетных элементов

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tayna73p00m0k
24.07.2021 16:10

//c++

#include <iostream>

#include <cmath>

#include <ctime>

using namespace std;

signed main() {

srand(time(NULL));

setlocale(LC_ALL, "Rus");

int matrix[5][5];

long int pr = 1;

cout << "Сгенерированная матрица: " << endl;

for (int i = 0; i < 5; i++) {

 for (int j = 0; j < 5; j++) {

  matrix[i][j] = rand() % 15;

  cout << matrix[i][j] << " ";

  if (matrix[i][j] % 2 != 0)

   pr *= matrix[i][j];

 }

 cout << endl;

}

cout << "\nПроизведение нечетных элементов: " << pr << endl;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота