wwwvadimsokol
09.11.2021 03:01

По программированию на с++ с использованием оператора for () написать программу, которая будет выводить на экран: «введи размерность», затем считывать введенное с клавиатуры целое число и выводить на экран таблицу умножения вида: (если введено 3) 1 2 3 1 1 2 3 2 2 4 6 3 3 6 9

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
usik6
22.06.2020 06:38

#include <iostream>

using namespace std;

int main(){

setlocale(LC_ALL, "Russian");

int a;

cout<<"Введи размерность"<<endl;

cin>>a;

int arr[a+1][a+1];

for (int i=1; i<a+1; ++i)

 for(int j=1; j<a+1; ++j)

  arr[i][j]=i*j;

for (int i=1; i<a+1; ++i) {arr[i][0]=i;arr[0][i]=i;}

cout<<"  ";

for (int i=1; i<a+1; ++i){cout<<arr[i][0]<<" ";}

cout<<endl;

for (int i=1; i<a+1; ++i){

 for(int j=0; j<a+1; ++j)

  cout<<arr[i][j]<<" ";

 cout<<endl;

}

return 0;

}

Т.к. в условии про оформление ничего не сказано, то сделал самое обычное

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота