famm2
09.12.2020 22:41

Составьте программу, которая заполняет массив случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значения.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tyomking
22.06.2020 12:20
Program Zadacha;
Var a: Array [1..8] of Integer;
i, b, c: Integer;
Begin
Randomize;
For i := 1 To 8 Do
a[i] := Random(11);
b := 0;
c := 0;
For i := 1 To 8 Do
Begin
If a[i] Mod 2 = 1 Then
b := b + 1
Elsec := c + a[i];
End;
WriteLn('Количество нечетных элементов массива равно ', b);
WriteLn('Сумма четных элементов массива равна ', c);
ReadLn;
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота