support38
23.06.2021 23:39

Мне ! решить 2 по ивт в паскале: 1)составить программу вычисления в массиве a(n) произведения нечетных элементов 2)составьте программу вычисления в массиве b(n) максимального среди отрицательных элементов и его номера. заранее огромное ! нужно!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Yournick
21.06.2020 12:03
Var a: array [0..10] of integer;
    i, m: integer;
begin
     m := 1;
          for i := 0 to 10 do
     begin
          a[i] := random(50) - 25;
          writeln('[', i, '] => ', a[i]);
     end;

     for i := 0 to 10 do
         if (a[i] mod 2 = 1) then m := m * a[i];
     writeln(m);
end.

2)
var a: array [0..10] of integer;
    i, m: integer;
begin
     for i := 0 to 10 do
     begin
          a[i] := random(50) - 25;
          writeln('[', i, '] => ', a[i]);
     end;
          for i := 0 to 10 do
         if ((a[i] > a[m]) and (a[i] < 0)) then
            m := i;

     writeln('[', m, '] => ', a[m]);
end.

Можно и меньше циклов, это я для наглядности, чтобы всё не смешивалось =)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота