арина12324
01.01.2020 03:00

Составить программу, решающую следующую : вы продавец, и у вас имеются гири весом 1, 2, 5 кг. наберите минимальное количество гирь для взвешивания n кг.язык программирования-паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
buzaeva2013
21.06.2020 07:23
Var N, a, b: integer;
begin
     readln(N);
     a := N div 5;
     N := N mod 5;
     b := N div 2;
     WriteLn(a, 'x5, ', b, 'x2, ', N mod 2, 'x1');
end.

Вот так, делением можно)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота