emmavalse
04.01.2022 09:16

Составить программу и блок-схему, определяющую принадлежит ли точка с координатами (X, Y) множеству точек плоскости, изображенному на рисунке на языке Паскаль


Составить программу и блок-схему, определяющую принадлежит ли точка с координатами (X, Y) множеству

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
iten228
23.06.2021 19:59

Free Pascal

uses Classes;

var

 p: TPoint;

begin

 writeln('input X:');

 readln(p.x);

 writeln('input Y:');

 readln(p.y);

 if (sqr(p.x) + sqr(p.y) <= 25) and (p.x<=0) and (p.y>=0) then

   writeln('Yes')

 else

   writeln('No')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота