farkhod88
23.04.2021 10:31

Напишите программу, которая переводит число в 10-й с/с в 2-ую с/с через цикл while.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
angelinalitvine
25.04.2021 14:30

#include "stdafx.h"

#include <iostream>

using namespace std;

 

int main() {

   setlocale(LC_ALL, "Russian");

   int n;

   cout << "Введите число" << endl;

   cin >> n;

   while (n > 0) {

   (n%2 == 0) ? cout << "0" : cout << "1";

   (n%2 == 0) ? n = (n) / 2 : n = (n-1) / 2;  

   }

   cout << endl;

   system("pause");

   return 0;

}

var ch,new,st_10:integer;

begin

 writeln('Введи число');

 readln(ch);

 st_10:=1;

 while ch<>0 do

 begin

  new:=new+(ch mod 2)*st_10;

  ch:=ch div 2;

  st_10:=st_10*10;

 end;

 writeln('Число в двоичной системе сч.- ',new);

end.

Объяснение:

1)язык c++, 2) Паскаль, поставь лайк )

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота