Лиана891
29.03.2023 12:07

Попробуйте написать программу в python.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mriya1987
28.10.2022 01:59

Вам нужно:

1) перевести строку в массив символов

2) узнать длину полученного массива

3) создать ещё один пустой символьный массив

4) создать цикл, в котором будут записываться элементы первого массива во второй, пока не встретится запятая. если же встретилась запятая, то заканчиваем выполнение цикла

5) узнать размер нового массива, который состоит из букв первого слова

6) вывести последний элемент нового массива, что и будет последней буквой первого слова

алгоритм, в общем-то, такой. Вам нужно лишь перевести это в код на нужном языке программирования

0,0(0 оценок)
Ответ:
баги82
23.04.2020 03:29

#include <iostream>

#include <string>

 

bool check_func(char ch)

{

   if(ch == ' ' || ch == ',')

       return true;

   return false;

}

 

int main()

{

   std::string s;

   int index = 0, counter = 0;

   std::cout << "Enter string: ";

   getline(std::cin, s);

   

   while(s[index])

   {

       if(!check_func(s[index]))

       {

           while(!check_func(s[index]))

           {

               index++;

           }

           counter++;

       }

       index++;

   }

   

   std::cout << counter << "\n";

   

   system("pause");

   return 0;    

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота