nurbo55555555551
14.01.2021 23:07

Сделать на языке python! Дан целочисленный массив А из N элементов. Проверьте, есть ли в нем элементы, равные нулю. Если есть, найдите номер первого из них, т. е. наименьшее i, при котором элемент ai = 0.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Тася221
01.06.2023 14:14

Использовать латиницу

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
using std::strtok;

int main()
{
    char s[100];
    char *temp1;
    char *temp2;

    cout << "Enter the name and surname: ";
    cin.getline(s, 100);

    temp1 = strtok(s, " ");
    temp2 = strtok(NULL, " ");

    if(*(temp1 + strlen(temp1) - 1) == *(temp2 + strlen(temp2) - 2))
    {
        cout << "true" << endl;
    }
    else
        cout << "false" << endl;

   return 0;
}


Умоляю, составить с клавиатуры одной строкой вводят имя и фамилию через пробел.составьте программу,к
0,0(0 оценок)
Ответ:
Vasilyeva5
29.12.2020 08:09

Program Program1;
Var
a:array [1..10] of integer;
i,min,max, Nmin, Nmax:integer;

//Процедура рекурсивной инвресии массива
procedure InvertMas(nac,kon:integer);
var
temp:integer;
begin
temp:=a[nac];
a[nac]:=a[kon];
a[kon]:=temp;
if nac+1<kon-1 then InvertMas(nac+1,kon-1);
end;

begin
randomize;
//Заполняем массив случайнами числами и выводим его на экран
writeln('Массив до инверсии:');
for i:=1 to 10 do
begin
a[i]:=random(100);
writeln('a['+inttostr(i)+']='+inttostr(a[i]));
end;
//Находим самый левый минимальный элемент в первой половине массива и номер этого элемента
Nmin:=1;
min:=a[Nmin];
for i:=1 to 5 do
if min>a[i] then
begin
min:=a[i];
Nmin:=i;
end;
//Находим самый правый максимальный элемент во второй половине массива и номер этого элемента
Nmax:=10;
max:=a[Nmax];
for i:=10 downto 6 do
if max<a[i] then
begin
max:=a[i];
Nmax:=i;
end;

writeln;
writeln('Инвертируем часть массива с '+inttostr(Nmin)+' по '+inttostr(Nmax)+' элемент');
//Инвертируем часть массива с Nmin по Nmax
invertmas(Nmin,Nmax);

//Выводим массив после инверсии на экран
writeln;
writeln('Массив после инверсии:');
for i:=1 to 10 do writeln('a['+inttostr(i)+']='+inttostr(a[i]));

end.


Необходимо составить программу с использованием рекурсии замечание: под инвертированием понимают пер
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота