alice1607
21.03.2021 21:12

1) Составить программу, которая запрашивает целое трёхзначное число и на экран выдаёт остаток от деления этого числа на 100. 2) Напишите программу нахождения минимального и максимального из 3-х чисел, введённых с клавиатуры.
3) Вычислить среднее арифметическое 3-х чисел, введенных с клавиатуры
4) Журавлики
Петя, Катя и Сережа делают из бумаги журавликов. Вместе они сделали S журавликов. Сколько журавликов сделал каждый ребенок, если известно, что Петя и Сережа сделали одинаковое количество журавликов, а Катя сделала в два раза больше журавликов, чем Петя и Сережа вместе?
Программа запрашивает одно натуральное число S – общее количество сделанных журавликов.
Нужно вывести три числа, разделенных пробелами – количество журавликов, которые сделал каждый ребенок (Петя, Катя и Сережа).

Примеры

№ Ввод Вывод

1 6 1 4 1

2 24 4 16 4

3 60 10 40 10

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
artemssh2
07.01.2021 10:21

"...напечатает сначала 2, потом - 6" -- это значит a=2 и b=6?


про пятеричные записи ничего не понял...  :) И ИМХО к чему такие сложности? И для чего нам комп и программа? Я подправил исходную прогу чтобы она выдавала все числа подходящие по условию

var x,a,b: longint;


begin

   for var i := 999 DownTo 100 do begin

       a := 0;

       b := 1;

       x := i;

       while x>0 do begin

           if x mod 2 > 0 then a := a+1 else b := b+(x mod 5);

           x := x div 5;

       end;

       if (a = 2) and (b = 6) then writeln('x = ', i, ' a = ', a, ' b = ',b);

   end;

end.


прога проводит расчет для всх трехзначных чисел от 999 до 100

итого мы видим что максимальное подходящее число это 960

при необходимости прогу можно переделать чтобы она находила только максимальное число.

0,0(0 оценок)
Ответ:
НикитаПахомов1
10.07.2021 22:01

Однозадачные ОС предоставляют пользователю виртуальную машину и включают средства управления файлами, периферийными устройствами и средства общения с пользователем.

Многозадачные ОС дополнительно управляют разделением между задачами совместно используемых ресурсов.

Многозадачность бывает невытесняющая (NetWare, Windows3/95/98) и вытесняющая (Windows NT, OS/2, UNIX).

В первом случае активный процесс по окончании сам передает управление ОС для выбора из очереди другого процесса.

Во втором — решение о переключении процессора с одного процесса на другой принимает ОС.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота