anast200397
24.12.2020 10:05

3 Составьте программу нахождения гипотенузы прямоугольного треугольника в PascalABC
P.S. Для того, чтобы быстрее справиться с заданием, советую создать небольшой
шаблон программы на Паскале, и использовать его для написания программ.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
gavrikov
05.10.2022 10:55
Делалось из рассчета что 4 записывается 4 единицами и тп
Для N = 3500 и М = 5 будет выбрано 216 чисел

const
    symbols_count = 7;
    symbols: array[1..symbols_count] of integer = (1000, 500, 100, 50, 10, 5, 1);

var
    num, n, m, c, i, j, res: integer;

begin
    readln(n, m);
    
    for i := 1 to n do
    begin
        num := i;
        c := 0;
        for j := 1 to symbols_count do
            if num >= symbols[j] then
            begin
                c := c + num div symbols[j];
                num := num mod symbols[j];
            end;
            
        if c = m then begin
            {writeln(i);}
            res := res + 1;
        end;
    end;
    
    writeln(res);
end.
0,0(0 оценок)
Ответ:
sergnovop08ly5
28.02.2022 09:31
// PascalABC.NET 3.2, сборка 1387 от 20.02.2017
// Внимание! Если программа не работает, обновите версию!

№1
begin
  var n:=ReadInteger('Введите двухзначное целое:');
  (var p,var q):=(n div 10,n mod 10);
  if (p*q) mod 5=0 then Writeln('Да')
  else Writeln('Нет')
end.

№2
begin
  var n:=ReadInteger('Введите двухзначное целое:');
  (var p,var q):=(n div 10,n mod 10);
  Writeln(Max(p,q)*2)
end.

№3
begin
  var n:=ReadInteger('Введите двухзначное целое:');
  (var p,var q):=(n div 10,n mod 10);
  if p.IsEven then p*=3;
  if q.IsEven then q*=3;
  Println(p,q)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота