Salkin355
10.01.2021 15:34

1) Напишите программу на языке программирования Python, считающую количество элементов в массиве

2) Напишите алгоритм сортировки методом «Пузырька», используя программный код Python.

3) Дан двумерный массив. Выведите индекс строки и столбца, содержащие максимальный элемент массива.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Alterabars
16.03.2022 23:04
1.клавиатура,мышь,сканер.микрофон
2.процессор
3.чтение книги,толковый словарь,заучения правила(нащет видеокассеты зависит какое видео)
4.Backspace
5.Рабочий стол
6.операционная система
7.На ПЗУ (не знаю что это постояная память или жесткий диск
8.происходит обработка, связанная с изменением формы информации, но не изменяющая ее содержания
9.Название приложения,кнопка "Свернуть,кнопка "Закрыть",панель инструментов, палітра,рабочая область
10.Жесткий диск,флешка,лазерный диск (для DVD) ,SD-карты
11.Квадрат зелённый
0,0(0 оценок)
Ответ:
yaroslavaaf
20.10.2021 06:09
Замечание. Так как количество вводимых чисел заранее не известно, то откроем бесконечный цикл со всегда верным условием True, но как только будет введено число 0, остановим цикл командой break.

Программа:

program z;
var k,s,x:integer;
begin
k:=0;              {начальное значение количества двузначных чисел}
s:=0;              {начальное значение суммы двузначных чисел}
while True do  {открываем бесконечный цикл}
begin
readln(x);        {вводим число х}
if x=0 then break;  {если введенное число равно 0, то остановить цикл}
if (x>9)and(x<100) then  {если число двузначное, т.е. от 10 до 99} 
    begin 
    k:=k+1;         {количество увеличиваем на 1}
    s:=s+x;         {увеличиваем предыдущее значение суммы на число х}
    end;
end;
if k=0 then writeln('NO')  {если двузначных чисел не было, то вывод NO}
   else writeln(s/k);          {иначе вывод ср.арифметического}
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота