kirakoveduard
14.09.2021 21:52

Нужно написать программу на с++. Я сама написала программу ниже, но когда я ввожу 2, вместо -0.5 выходит найти ошибку


Нужно написать программу на с++. Я сама написала программу ниже, но когда я ввожу 2, вместо -0.5 вых
Нужно написать программу на с++. Я сама написала программу ниже, но когда я ввожу 2, вместо -0.5 вых

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
arisha20003000
08.03.2021 21:19

#include<iostream>

#include<cmath>

using namespace std;

int main()

{

int n;

cin >> n;

int p = 1;

float sum = 0;

for (float i = 1; i <=n; i++)

{

p *= i;

sum += (pow(-1, i) * (i + 1)) / (p);

}

cout << sum;

}

//вместо n ты должна была написать i

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота