dmxboy
30.08.2020 16:30

В соответствии с заданным вариантом написать программу вычисления выражения и составить блок-схему.


В соответствии с заданным вариантом написать программу вычисления выражения и составить блок-схему.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
annzhoravel461
03.06.2021 14:09
Uses crt;
type mas = array [1.. 8, 1.. 8] of integer;
var M:mas;i,j,k:integer;
a:array[1..28]of integer;
    begin
        randomize;
             for i:=1 to 8 do
              begin
                 for j:=1 to 8 do
                    begin
                        M[i,j]:=random(190)-95;
                         write(M[i,j]:4);
                     end;
                   writeln;
               end;
for i:=1 to 8 do   
    for j:=1 to 8 do       
           if i>j then           
               begin               
                   k:=k+1;               
                   a[k]:=m[i,j];           
               end;   
writeln;   
       for i:=1 to 28 do       
          write(a[i]:4);   
end.
0,0(0 оценок)
Ответ:
SamMary
09.05.2023 22:32
Function IsArmstrong(m As Long) As Boolean
    Dim s As Long, n As Integer, i As Integer, m1 As Long
    Dim d(1 To 15) As Long
    m1 = m: n = 0
    Do While m1 > 0
        n = n + 1
        d(n) = m1 Mod 10
        m1 = Int(m1 / 10)
    Loop
    s = 0
    For i = 1 To n
        s = s + d(i) ^ n
    Next i
    IsArmstrong = (s = m)
End Function

Sub Test()
    Dim k As Long, i As Long, j As Integer
    Cells.Clear
    k = CLng(InputBox("Введите значение k"))
    j = 1
    For i = 0 To k
        If IsArmstrong(i) Then
            Cells(j, 1) = i
            j = j + 1
        End If
    Next i
End Sub
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота