Напишите программу в Паскале, которая заполняет массив из N = 10 элементов случайными числами в диапазоне

[0,20], выводит его на экран, а затем находит индекс

первого элемента, равного введённому числу X.

Программа должна вывести ответ «не найден», если

в массиве таких элементов нет.

Пример:

Массив: 5 16 2 13 3 14 18 13 16 9

Что ищем: 13

A[4] = 13

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Лиля4032
14.01.2021 02:41

var a: array [1..10] of integer;

x,i: integer;

k: boolean;

begin

 k:=False;

 randomize;

 for i:=1 to 10 do

   a[i]:=random(21);

 readln(x);

 for i:=1 to 10 do

   if a[i]=x then

   begin

     x:=i;

     k:=True;

     break;

   end;

 if k then

   writeln('a[',x,']=',a[x])

 else

   writeln('не найдено')

end.

Объяснение:


Напишите программу в Паскале, которая заполняет массив из N = 10 элементов случайными числами в диап
Напишите программу в Паскале, которая заполняет массив из N = 10 элементов случайными числами в диап
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота