лоло97
24.04.2020 00:58

Составить программу для решения алгебраической неровности на языке С++ Программа должна для заданных
значений числовых коэффициентов a, b и c определять решение в виде
промежутков на числовой оси. Выполнить программу для различных значений
коэффициентов a, b и c так, чтобы продемонстрировать ее работу по всем
возможными ветками разветвления.


Составить программу для решения алгебраической неровности на языке С++ Программа должна для заданных

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
karvinatatiana
10.08.2022 14:21
Для всех заданий воспользуемся формулой N=2^i? где N -количество цветов, а i -количество бит на 1 пиксель.
Задача 1.
N=2^4=16 цветов.

Задача 2.
N=224=2^i, поскольку для кодирования 128 цветов необходимо 7 бит, а для кодирования 256 цветов -8 бит, выбираем большее число, то есть 8 бит или 1 байт.

Задача 3.
65536 это 2^16⇒требуется 16 бит или 2 байта.

Задача 4.
1. Узнаем общее количество пикселей 1280*1024=1310720
2. Полученное число умножаем на глубину цвета 1310720*32=41943040 бит = 41943040/8 = 5242880 байт = 5242880/1024 = 5120 кб =5120/1024 = 5 Мб
ответ: 5 Мб
0,0(0 оценок)
Ответ:
ОлесяБычкова
28.04.2022 16:00

1) если нужно найти произведение элементов с нечетными индексами:

#include <iostream>

#include <cmath>

#include <vector>

using namespace std;

signed main() {

   int a[20];

   srand(time(NULL));

   for(int i = 0; i < 20; i++)

       a[i] = rand()%46 - 19;

   for(auto i: a)

       cout << i << " ";

   cout << "\n";

   long long ans = 1;

   for(int i = 0; i < 20; i++)

       if(i % 2 == 1)

           ans *= a[i];

   cout << ans;

}

2) Если нужно найти произведение элементов с нечетными порядковыми номерами:

#include <iostream>

#include <cmath>

#include <vector>

using namespace std;

signed main() {

   int a[20];

   srand(time(NULL));

   for(int i = 0; i < 20; i++)

       a[i] = rand()%46 - 19;

   for(auto i: a)

       cout << i << " ";

   cout << "\n";

   long long ans = 1;

   for(int i = 0; i < 20; i++)

       if((i+1) % 2 == 1)

           ans *= a[i];

   cout << ans;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота