Yan132142
26.05.2022 02:41

Даны координаты трёх точек плоскости. Составить программу на языке Java, которая бы определяла бы вид треугольника (равносторонний, равнобедренный, разносторонний, прямоугольный, тупоугольный, остроугольный). Для ввода данных, вычислений и вывода данных использовать отдельные функции (методы). Не использовать глобальные переменные, все необходимые данные передавать в эти функции (методы).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lalka137
05.03.2021 12:25

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

// Variables

double a = 0, b = 0, c = 0;

double x;

double condition;

double sub_condition;

double y;

// Input

cout << "Input numbers:" << endl;

cout << "a = ";

cin >> a;

cout << "b = ";

cin >> b;

cout << "c = ";

cin >> c;

cout << "x = ";

cin >> x;

// Create condition

condition = abs(1 - pow(x, 2));

sub_condition = a + c;

//  Solution

if (condition == sub_condition) {

 y = sqrt(abs(a * x - pow(cos(pow(b, 3)), 2) * x + 5.1 * pow(c, 2)));

}

else if (condition > sub_condition) {

 y = exp(0.04 * x) + log(pow(b, 5) * cos(x));

}

else {

 y = pow(cos(pow(b, 3) * pow(x, 2)), 2) + log(abs(b * x - pow(a, 2)));

}

cout << "Answer: y = " << y << endl;

return 0;

}


Создать ОДНУ программу расчета функции y(x) для трех разных параметров на С++. Переменная x вводится
0,0(0 оценок)
Ответ:
vikap754p08qzb
19.06.2021 16:31

Объяснение:

#include <iostream>

using namespace std;

long double fact(int N)

{

   if(N < 0) // если пользователь ввел отрицательное число

       return 0; // возвращаем ноль

   if (N == 0) // если пользователь ввел ноль,

       return 1; // возвращаем факториал от нуля - не удивляетесь, но это 1 =)

   else // Во всех остальных случаях

       return N * fact(N - 1); // делаем рекурсию.

}

int main()

{

   int N;

   setlocale(0,""); // Включаем кириллицу

   cout << "Введите число для вычисления факториала: ";

   cin >> N;

   cout << "Факториал для числа " << N << " = " << fact(N) << endl << endl; // fact(N) - функция для вычисления факториала.

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота