1ivel3
01.11.2021 17:45

Можно программу на языке паскаль ":) Составить программу нахождения суммы всех делителей заданного натурального числа N.
(Само число и единица включаются в число делителей.)

Формат входных данных
Входной файл содержит число N (1≤N≤1000).

Формат выходных данных
Выведите искомую сумму.

Примеры:
Вход
3
Выход
4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alanasia2004
12.01.2021 13:36

var sum,i,N:integer; t,t1:text;

begin

 assign (t, 'input.txt'); reset(t);

 assign (t1, 'output.txt'); rewrite(t1);

read(t,N);

sum:=0;

for i:=1 to N do

 if N mod i = 0 then sum:= sum+i;

write(t1,sum);

close(t1)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота