крист34
14.04.2023 11:52

Задачи на списки в Python: 1. Дан массив размера N. Найти минимальный из его локальных максимумов
2. На обработку поступает последовательность из четырёх целых чисел. Нужно написать программу, которая выводит на экран количество неотрицательных чисел последовательности и их произведение. Если неотрицательных чисел нет, требуется вывести на экран «NO». Известно, что вводимые числа по абсолютной величине не превышают 10.
3. На обработку поступает последовательность из четырёх целых чисел. Нужно написать программу, которая выводит на экран сумму всех отрицательных чисел последовательности и максимальное число в последовательности.
Известно, что вводимые числа по абсолютной величине не превышают 1000.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tatiana342
31.07.2020 04:55

Операцио́нная систе́ма, сокр. ОС (англ. operating system, OS) — комплекс взаимосвязанных программ, предназначенных для управления ресурсами компьютера и организации взаимодействия с пользователем.

В логической структуре типичной вычислительной системы операционная система занимает положение между устройствами с их микроархитектурой, машинным языком и, возможно, собственными (встроенными) микропрограммами (драйверами) — с одной стороны — и прикладными программами с другой.

Разработчикам программного обеспечения операционная система позволяет абстрагироваться от деталей реализации и функционирования устройств, предоставляя минимально необходимый набор функций (см.: интерфейс программирования приложений).

В большинстве вычислительных систем операционная система является основной, наиболее важной (а иногда и единственной) частью системного программного обеспечения. С 1990-х годов наиболее распространёнными операционными системами являются системы семейства Windows, Unix и UNIX-подобные системы.

0,0(0 оценок)
Ответ:
marinalebedeva5
04.02.2022 01:23
#include <iostream>#include <math.h>using namespace std;#include <locale.h>/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int main(int argc, char** argv) { setlocale(LC_ALL,"rus"); int e, f, g, h, w; cin>>e>>f>>g>>h>>w; float a, b, c, D; a = (e+f/2)/3; b = abs(pow(h,2) - w); c = sqrt(pow(g- h,2) - 3 * sin(e)); D = pow(b,2) - 4 * a * c; cout<<"a = "<<a<<", b = "<<b<<", c = "<<c<<", D = "<<D<<"."; return 0;}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота