Жекон124
06.05.2020 04:49

Python 3.7
напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. в конце работы программы на экран выводятся количество чисел (0 не считаем), минимальное и максимальное из введенных чисел, их сумму и среднее значение.
заранее большое

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Still227
10.10.2020 06:09

{с клавиатуры вводится число a, до тех пор, пока не будет введен 0. Начальное введенное a записывается в min  и max, чтобы потом в цикле было с чем сравнивать}

var

min,max,a:real;

begin

  readln(a);

  min:=a;max:=a;

   while a<>0 do

       begin

            readln(a);

                if a>max then

                    max:=a;

                if a<min then

                     min:=a;

        end;

writeln('min: ',min,'  max: ',max);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота