эдвард20
13.05.2020 15:54

Программа в С++ Метеоритный дождь

В солнечный декабрьский зимний день ничего не предвещало беды. Так думала и команда, которая решила написать очередной контест. Для написания контеста организатор подготовил несколько компьютеров. Все они пронумерованы числами от 1 до 113. Однако, когда команда пришла к началу контеста, случилось так, что почти все компьютеры были заняты - все, кроме 4-х. Команде нужно было быстро выбрать компьютер, и она уже начала справляться со сложной проблемой выбора, как вдруг по радио объявили, что сегодня будет метеоритный дождь. Причём достоверно известно, что на три из четырёх свободных компьютеров упадёт по метеориту. Так как команда не хочет быть раздавленной метеоритом, ей необходимо выбрать безопасный компьютер. Однако выбор - сложный и долгий процесс, а команда хочет хорошо выступить, поэтому им нельзя терять время ещё на один поиск им!

Входные данные:
В первой строке вам даны 4 числа - номера свободных компьютеров. Все они - различные целые числа, не превосходящие 113.

Во второй строке вам даны 3 числа - номера компьютеров, на которые упадёт метеорит. Гарантируется, что эти номера различны и что все соответствующие компьютеры свободны.

Выходные данные:
Выведите единственное число - номер компьютера, который следует выбрать команде.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
11111269
05.12.2021 03:12

#include <iostream>

#include <vector>

using namespace std;

int main() {

setlocale(0, "");

vector<int> arr;

cout << "Количество чисел: \n";

int n, temp, min = 2147483647, max = -2147483648, minIndex = 0, maxIndex = 0;

long long sum = 0;

cin >> n;

for (int i = 1; i <= n; ++i) {

 cout << i - 1 << ": ";

 cin >> temp;

 arr.push_back(temp);

 if (temp < min)

  (min = temp) && (minIndex = i - 1);

 if (temp > max)

  (max = temp) && (maxIndex = i - 1);

}

cout << "Минимальный элемент: " << min << ", располагается по индексу " << minIndex << endl;

cout << "Максимальный элемент: " << max << ", располагается по индексу " << maxIndex << endl;

for (int i = minIndex + 1; i < maxIndex; ++i)

 sum += arr[i];

cout << "Сумма элементов с " << minIndex + 1 << " по " << maxIndex - 1 << " включительно: " << sum << endl;

cout << "Среднее значение элементов с " << minIndex + 1 << " по " << maxIndex - 1 << " включительно: " << sum / (maxIndex - minIndex - 1) << endl;

return 0;

}


С++ В одновимірному масиві знайти суму та середне значення елементів, що знаходяться між мінімальним
С++ В одновимірному масиві знайти суму та середне значення елементів, що знаходяться між мінімальним
0,0(0 оценок)
Ответ:
ksysharoma123
05.12.2021 03:12

Відповідь:

Пояснення:

#include <iostream>

using namespace std;

int main()

{

   int *arr;

   int size;

   int k, m, s, sr;

   k=0;

   m=0;

   s=0;

   sr=0;

   cin >> size;

   arr = new int[size];

   for (int i = 0; i < size; i++) {

       cin >> arr[i];

   }

     for (int i = 1; i < size; i++) {

       if (arr[i] > arr[i-1])

          k++;

     }

    for (int i = 1; i < size; i++) {

       if (arr[i] < arr[i-1])

          m++;

  }

  if (k < m){

      for (int i = k; i < m; i++){

      s = s + arr[i];

      sr = s/(m - k);

      }

  }

  else {

   for (int i = m; i < k; i++){

      s = s + arr[i];

      sr = s/(k - m);

      }

  }

cout<<s<< endl;

cout<<sr<< endl;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота