Составить программу на Паскале: Создать одномерный массив из 12 целочисленных элементов с именем f.
Массив заполнить случайными числами от -10 до 10.
Найти сумму положительных элементов массива. (положительные значения >0).
Вывести на экран значение элементов массива в строчку и на новой строке вывести сумму элементов массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lesja021
11.02.2023 16:11
// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
begin
  Write(Range(300,400,2).Sum)
end.

Результат выполнения программы:
17850

// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
begin
  Range(104,999,8).Print
end.

Результат выполнения программы:
104 112 120 128 136 144 152 160 168 176 184 192 200 208 216 224 232 240 248 256 264 272 280 288 296 304 312 320 328 336 344 352 360 368 376 384 392 400 408 416 424 432 440 448 456 464 472 480 488 496 504 512 520 528 536 544 552 560 568 576 584 592 600 608 616 624 632 640 648 656 664 672 680 688 696 704 712 720 728 736 744 752 760 768 776 784 792 800 808 816 824 832 840 848 856 864 872 880 888 896 904 912 920 928 936 944 952 960 968 976 984 992
0,0(0 оценок)
Ответ:
Vladislava111111111
19.05.2020 12:00
Рассматриваем движение тела, брошенного под углом к горизонту без начального ускорения. Уравнения движения тела в осях координат известны из физики:
\begin {cases} x=v_0t\cdot \cos\alpha \\ \displaystyle y=v_0t\cdot \sin\alpha-\frac{gt^2}{2} \end {cases}
Также известна формула для определения времени движения тела до его падения (т.е. возвращения на исходную высоту, которая совпадает с осью X):
\displaystyle t= \frac{2v_0\sin\alpha}{g}
Считаем, что в начальных условиях задается количество точек, в которых нужно найти значения пути пройденного в осях координат.

uses Crt;
const
   g=9.81;
   pi=3.14;
var
   alpha,ar,v0,t,x,y,tmax,ht,v0x,v0y:real;
   n:integer;
begin
   ClrScr;
   Write('Vvedite alpha, v0: ');
   Read(alpha,v0);
   Write('Chislo tochek= ');
   Read(n);
   ar:=pi*alpha/180;
   v0x:=v0*cos(ar);
   v0y:=v0*sin(ar);
   tmax:=2*v0*sin(ar)/g;
   ht:=tmax/n;
   t:=ht;
   while t<=tmax do
   begin
      x:=v0x*t; y:=v0y*t-g*sqr(t)/2;
      Writeln('t=',t:6:3,' x=',x:8:3,' y=',y:8:3);
      t:=t+ht
   end;
   ReadKey
end.

Тестовое решение:
Vvedite alpha, v0: 45 126.4
Chislo tochek= 10
t= 1.821 x= 162.864 y= 146.461
t= 3.643 x= 325.728 y= 260.375
t= 5.464 x= 488.592 y= 341.742
t= 7.286 x= 651.456 y= 390.562
t= 9.107 x= 814.320 y= 406.836
t=10.929 x= 977.184 y= 390.562
t=12.750 x=1140.048 y= 341.742
t=14.572 x=1302.912 y= 260.375
t=16.393 x=1465.776 y= 146.461
t=18.215 x=1628.640 y=   0.000
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота