Рост2006
01.04.2023 02:56

Составить программу, , нужно ! пятиугольник abcde задан координатами своих вершин (x1,y1)(x2,y2)(x3,y3)(x4,y4)(x5,y5) соответственно. найти площадь этого пятиугольника используя в качестве подпрограммы a) функцию

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
coldsssiemens
12.06.2020 09:46

#include <iostream>

using namespace std;

 

struct my{

   int x;

   int y;

}

 

void S_size() ;

 

int main()

{
   my my_struct = new my[5];

   for(int i =0 ;i<5;i++)

{

  cin >> my_struct[i].x;

  cin >> my_struct[i].y;

 

S_size();

}

 

S_size()

{

  double S = 0.5*((my_struct[0].x*my_struct[1].y)-(my_struct[1].x *my_struct[0].y))*((my_struct[1].x * my_struct[2].y)-(my_struct[2].x*my_struct[1].y))*((my_struct[2].x * my_struct[3].y)-(my_struct[3].x*my_struct[2].y))*((my_struct[3].x * my_struct[4].y)- (my_struct[4].x*my_struct[3].y));

cout << S ;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота