jjjghhgg6
04.07.2022 03:08

Напишите программу для подсчёта суммы и произведения вводимого числа​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
литературщик
16.12.2020 12:13

var

       sum, comp: Int64;

       i: Word;

       s: string;

       

begin

       Read (s);

       

       sum := 0;

       comp := Ord (s[1]) - 48;

       

       for i := 1 to Length (s) do

               sum := sum + Ord (s[i]) - 48;

       

       for i := 2 to Length (s) do

               comp := comp * Ord (s[i]) - 48;

               

       WriteLn ('Сумма цифр в числе ', s, ' = ', sum);    

       Write ('Произведение цифр в числе ', s, ' = ', comp);

end.


Напишите программу для подсчёта суммы и произведения вводимого числа​
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота