alenalille300
15.11.2021 18:37

Напишите программу на языке Pascal, используя цикл «repeat». Составьте блок - схему:


s = \cos(x) + \cos(2)x + \cos(3)x + ... + \cos(13)x
Напишите программу на языке Pascal, используя цикл «repeat». Составьте блок - схему:​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sabama
14.03.2022 06:39
Лучше писать результат не в тот же файл, а в другой: при составлении регулярных выражений без достаточного опыта можно легко ошибиться.

uses
  System.Text.RegularExpressions;

const
  CRLF = #13#10;

var
  s, sbig: string;
  fin, fout: Text;

begin
  Assign(fin, 'MyIn.txt');
  Reset(fin);
  sbig := '';
  while not Eof(fin) do
  begin
    Readln(fin, s);
    sbig := sbig + s + CRLF
  end;
  Close(fin);
  {пример - уладить подстроки, начиная с "http:" и до первого пробела,
  причем внутри подстроки может встретиться переход на новую строчку.
  Используется шаблон '\bhttp:\S+' - подробности: регулярные выражения}
  sbig:=RegEx.Replace(sbig, '\bhttp:\S+', '', RegexOptions.Multiline);
  Assign(fout, 'MyOut.txt');
  Rewrite(fout);
  Write(fout, sbig);
  Close(fout);
  Writeln('Конец работы');
end.
0,0(0 оценок)
Ответ:
vikapuhtina
27.06.2020 09:50
Y>12 - это не произведение, а неравенство. Его результат - значение "истинно" или "ложно".
1. Определиться, в строке или в колонке располагать данные. Например, принято решение, что данные будут располагаться в колонке А.
2. В колонке А, начиная с любой строки, например, со строки 4 запишем сверху вниз наши значения: 1, 6, 8, 10, 13, 14. Если сделать все, как тут написано, значение 14 должно попасть в ячейку А9.
3. В колонке B рядом с данными поместим формулу, по которой нужно сделать вычисление. Становимся в ячейку B4 и вводим в ней формулу =A4>12
В Excel запись формулы всегда начинается со знака равенства, причем сам этот знак лишь означает, что дальше идет формула, а в самой формуле он не учитывается. A4 - это адрес (координаты) ячейки, где содержится Y, поэтому формула =A4>12 понимается так: вычислить, больше ли содержимое ячейки А4, чем 12. Результат будет вычислен и записан в ячейке B4 на месте формулы. Для операций отношения Excel выдает результат в форме значения ИСТИНА и ЛОЖЬ. В данном случае 1<12, поэтому значением Y>12 будет ЛОЖЬ.
Теперь эту же формулу надо разместить в остальных ячейках В5-В9. Это можно сделать несколькими
а) Самый глупый. Записать в каждой ячейке нужную формулу. А если таких ячеек сто? Или 1000?
б) "Для забывашек". Шелкнуть мышкой в ячейке В4 и скопировать в буфер её содержимое, воспользовавшись меню или введя Ctrl+C. Затем выделить группу ячеек с В5 по В9 и выполнить операцию вставки из буфера через меню или введя Ctrl+V. Excel выполнит "умное" копирование и щелкнув любую из ячеек из В5-В9 модно убедиться, что адрес А4 изменился на адрес нужной строки.
в) Скопировать перетаскиванием. Щелкнуть мышкой в ячейке А4. Вокруг ячейки появится толстая рамка выделения с жирной точкой в правом нижнем углу. Навести мышку на эту точку и курсор превратится в знак "плюс". Далее зажать левую кнопку мышки и перетащить курсор вниз пока не окажутся выделенными все ячейки, куда надо выполнить копирование. Затем отпустить левую кнопку мыши. Все, формулы "размножены", причем тоже "умно".
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота