арсен187
09.04.2022 17:17

с информатикой. Написать программу:
Массив из 30 элементов заполнить случайным образом целыми числами от 0 до 10, найти сумму всех его элементов и вывести её на экран.
Я начала писать ( на фото), но не уверена и не знаю, что дальше

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nasa21p08m1i
03.08.2020 07:50

Ты почти правильно все написала :)

var a : array[1..30] of integer;  // определяем массив, который будет состоять из 30 чисел типа integer (целых)

   i, sum : integer;  // Переменная i для итерации в цикле, sum - для суммы

begin

 sum := 0; //В начале сумма равна нулю

 randomize(); //инизициализиуем датчик псевдослучайных чисел

 for i := 1 to 30 do begin  // цикл, который будет повторяться 30 раз

   a[i] := random(0,10);  // Говорим, что элемент с индексом i в массиве равен рандомному числу от 0 до 10

   sum := sum + a[i];  // Прибавляем к переменной sum элемент массива с индексом i

 end;

 write('Сумма: ' + sum) //Выводим

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота