olga638
25.05.2021 11:39

Написать программу на делфи(ну или на паскале) все компоненты вещественного вектора а(а1,),начиная с первого по порядку положительной компоненты,уменьшить на 1

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
User5281
09.05.2022 06:42
Const
  n=20;
type
  S=array[1..n] of integer;

procedure SGen(a,b:integer; var m:S);
{ Заполняет массив m случайными числами из интервала [a;b] }
var
  i:integer;
begin
  Randomize;
  for i:=1 to n do m[i]:=Random(b-a+1)+a
end;

procedure SWrite(SName:char; a:S);
{ Выводит массив a с указанием имени SName в заголовке }
var
  i:integer;
begin
  Writeln('Последовательноcть ',SName);
  for i:=1 to n do Write(a[i],' ');
  Writeln
end;

function SZeros(a:S):integer;
{ Возвращает количество нулей в массиве a }
var
  i,k:integer;
begin
  k:=0;
  for i:=1 to n do
    if a[i]=0 then Inc(k);
  SZeros:=k
end;

var
  a,b,c,d,r:S;
  nr:char;
  za,zb,zc,zd,zr,i,mx:integer;
begin
  SGen(-5,5,a); SWrite('A',a); za:=SZeros(a);
  r:=a; nr:='A'; zr:=za;
  repeat
    SGen(-8,9,b); zb:=SZeros(b);
  until zb<>zr;
  SWrite('B',b);
  if zb>zr then begin r:=b; nr:='B'; zr:=zb end;
  repeat
    SGen(-9,3,c); zc:=SZeros(c);
  until zc<>zr;
  SWrite('C',c);
  if zc>zr then begin r:=c; nr:='C'; zr:=zc end;
  repeat
    SGen(-2,7,d); zd:=SZeros(d);
  until zd<>zr;
  SWrite('D',d);
  if zd>zr then begin r:=d; nr:='D'; zr:=zd end;
  mx:=r[1];
  for i:=2 to n do
    if r[i]>mx then mx:=r[i];
  for i:=1 to n do
    if r[i]=0 then r[i]:=mx;
  Writeln;
  SWrite(nr,r)
end.

Контрольное выполнение

Последовательноcть A
-5 4 0 -1 2 -1 4 -5 3 3 1 5 -2 1 -1 -5 -1 -1 0 4
Последовательноcть B
-1 1 4 6 8 -1 -8 -8 5 4 -2 0 -2 8 3 -8 -6 -3 9 -7
Последовательноcть C
-4 -3 0 1 2 -4 -9 -9 0 0 -5 -4 -5 2 -1 -9 -8 -5 3 -8
Последовательноcть D
1 3 5 5 7 2 -2 -2 5 5 1 2 1 6 4 -2 -1 1 7 -2

Последовательноcть C
-4 -3 3 1 2 -4 -9 -9 3 3 -5 -4 -5 2 -1 -9 -8 -5 3 -8
0,0(0 оценок)
Ответ:
dinok3
02.05.2023 19:36
Самое главное для корпуса системного блока это его габариты. Можно выделить несколько типоразмеров компьютерных корпусов Barebone, Slim, MiniTower, MidiTower, FullTower и BigTower (от Tower — башня), и столько же форм-факторов: АТ, ATX, E-ATX, mATX, miniITX, XL-ATX. Все они связаны между собой габаритными размерами. Например: корпус Big -Tower (большая башня) имеет форм-фактор XL-ATX с размерами корпуса около 234 х 600 х 555 мм, а маленькая башня Mini-Tower имеет форм-фактор mATX с размерами 181 х 363 х 400 мм (ширина х длина х высота).
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота