лиьомьм
08.06.2021 14:29

Написать программу по условиям:

При одном своём сокращении сердце выбрасывает в аорту примерно 60 мл крови. Вычислите. какой объём крови сердце перекачивает за 1 минуту при условии, что частота сердечных сокращений равна 70 ударов в минуту. Определите по данному алгоритму, через какое время (в минутах) сердце перекачает 420л крови

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
labzaekaterina
23.11.2021 00:34

Смотрите, в двоичной системе исчесления все меряется в битах и байтах. 0000 0000, это байт, т.к. состоит из восьми бит. Биты же бывают положительными и отрицательными, равняются положительные единице, отрицательные же нулю. Но тут важно понимать, как ПК воспринимает эти числа. Число 5 будет выглядить как 0000 1001, потоиу что в байте сложили числа 1 и 4 (00000001 и 00001000), на то эта система и двоичная, т.к. нечетные числа получают путем складывания четных. Путем включения каждого бита отдельно мы получим такие числа, как

00000001 - 1. 00000010 - 2. 00000100 - 4. 00001000 - 8. 00010000 - 16. 00100000 - 32. 01000000 - 64. 10000000 - 128. Число 129 займет два байта, а значит у Горыныча не останется места для голов. ответ - он умрет от нехватки битов в байтах.

0,0(0 оценок)
Ответ:
geniynayk
12.11.2022 08:53

Ну, наверное это должно выглядеть как то так. Я плохо помню паскаль

program Help;   #Заголовок

var  #Раздел с переменными

a, b ,c, summ : real;   #Входные переменные и по итогу их сумма, вещественные

begin  #Думаю понятно

   summ := 0;   #Инициализация summ, ибо статическая типизация

   writeln('Enter nums');   #Программа попросит ввести числа

   readln(a);  #Считывание

   readln(b);  #Считывание

   readln(c);  #Считывание

   

   if a > 0 then summ += a;  #Если переменная а больше нуля, прибавляем её к итоговой переменной

   if b > 0 then summ += b;  #Аналогично

   if c > 0 then summ += c;   #Аналогично

   

   write(summ);   #Выводим переменную summ на экран

       

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота