Артем2090
03.09.2020 18:09

Язык - Python
Развернуть элементы с нечетными индексами
Вам дан список целых чисел. Разверните элементы с нечетными индексами.
Входные данные
Вводится список чисел. Все числа списка не превосходят по модулю 100 и находятся на одной строке.
Выходные данные
Выведите получившийся список.
Примеры
Ввод
1 2 3 4 5
Вывод
1 4 3 2 5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
andrey440
15.10.2020 14:49

--- Python 3.8.3 ---

RawList = list(map(int, input().split()))

fLen = len(RawList)

HalfLen = fLen//2

for i in range(1, HalfLen+1, 2):

   RawList[i], RawList[fLen-i-1] = RawList[fLen-i-1], RawList[i]

print(*RawList)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота