filimonovajulia1
10.04.2021 20:54

1)составить программу нахождения сумма всех однозначный положительных чиспл 2)составить программу нахождения всех трехзначных четных чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
angelinafeodoro
23.07.2021 23:07

Сумма номеров страниц- это сумма арифметической прогрессии (с шагом= 1)  от 1 до n (номер последней прочитанной страницы).

Такая сумма равна:  n*(n+1) / 2 = Q

отсюда  n*(n+1) = 2Q

Так как n -целое, то можно просто посчитать целую часть от квадратного корня из 2Q  (также, я сделал проверку, правильную ли сумму ввели).

Сама программа:

алг

нач

цел Q, n

вывод "введите сумму номеров прочитанных страниц: "

ввод Q

n := int(sqrt(2*Q))

если n*(n+1) = 2*Q

то вывод "номер страницы = ", n

иначе вывод "неверная сумма номеров страниц"

все

кон



Решить в кумире! татьяна ларина,читала очередной французский роман, подсчитала сумму номеров прочита
0,0(0 оценок)
Ответ:
Ернур150400
27.06.2020 00:15

Ну... а что сложного? Создаёшь структуру, заполняешь её, и обрабатываешь условие на входном M:


#include <stdio.h>

#include <conio.h>

#include <locale.h>

int main(void) {

setlocale(LC_ALL, "russian");

struct months {

 char name[16];

 int days;

};

struct months m[12] = {

 {"Январь",   31},

 {"Февраль",  29},

 {"Март",     31},

 {"Апрель",   30},

 {"Май",      31},

 {"Июнь",     30},

 {"Июль",     31},

 {"Август",   31},

 {"Сентябрь", 30},

 {"Октябрь",  31},

 {"Ноябрь",   30},

 {"Декабрь",  31}

};

 

int M;

 

printf("Введите номер месяца: ");

scanf("%d", &M);

 

if (M > 0 && M < 13) {

 M--;

 

 if (m[M].days == 29 || m[M].days == 30) {

  printf("В месяце \"%s\" %d дней.", m[M].name, m[M].days);

 } else {

  printf("В месяце \"%s\" %d день.", m[M].name, m[M].days);

 }

} else {

 printf("Неизвестный месяц.");

}

 

getch();

 

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота