cmh3
25.01.2022 01:56

Pyton. Задайте символьный массив. Найдите и выведите на экран те элементы, которые начинаются на букву ''к''

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
semak03
20.05.2021 05:02
PROGRAM A24;
const
    max = 20;
    
var
    c:array[1..max]of integer;
    x:integer;
    i, k:byte;

BEGIN
  writeln('Заменить k-й элемент одномерного массива на 0, если этот элемент четный и на 1 если он нечетный');
  writeln(' ');

  writeln('Начальный Массив' );
  randomize;
  for i:=1 to max do begin
    c[i]:=random(-64,64);
    write(c[i], ' ');
  end;

  writeln(' ');
  writeln(' ');
 
  write('Введите k='); readln(k);
  writeln(' ');

  if odd(k) then
      c[k]:=1
  else
      c[k]:=0;

  writeln(' ');    
  writeln('Измененный массив' );  
  for i:=1 to max do
    write(c[i], ' ');
END.

Написать программу на паскале 20) заменить k-й элемент одномерного массива на 0, если этот элемент ч
0,0(0 оценок)
Ответ:
fortunazanna
17.09.2022 02:43
Все расчеты аналогичны тем, что даны в примере.
а) в системе 20 элементов и она допускает разбиение на 5 подсистем по 4 элемента в каждой; 
Всего связей 20·19 = 380.
При разбиении на 5 подсистем по 4 элемента в каждой:
Число связей между подсистемами 5·4 = 20, число связей внутри каждой подсистемы – 4·3 = 12. Всего 20 + 5·12 = 80 связей

б) в системе 100 элементов и она допускает разбиение на 10 подсистем по 10 элементов в каждой.
Всего связей 100·199 = 19900.
При разбиении на 10 подсистем по 10 элементов в каждой:
Число связей между подсистемами 10·9 = 90, число связей внутри каждой подсистемы – 10·9 = 90. Всего 90 + 10·90 = 990 связей
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота