Kaaaaktuuuus
20.07.2020 03:18

ЛЮДИ ДОБРЫЕ, КРАСАТУЛЕНЬКИ С ИНФОЙ Написать программу в паскале (тема строковый тип), которая запрашивает три строковые переменные: существительное, прилагательное и глагол, а затем выводит все варианты фраз с использованием введённых слов!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MigelAlemanValdes
30.08.2021 13:41
Program Project1;

var m:array [0..14] of integer; i:integer;

function IsPositive(a:integer):boolean;
begin
  result:=(a>-1);
end;

procedure work;
var min, max, count:integer;
begin
  count:=0;
  min:=m[0];
  max:=0;
  for i:=0 to 14 do begin
    if IsPositive(m[i]) then begin
      inc(count);
      if m[i]>max then max:=m[i];
      if m[i]<min then min:=m[i];
    end;
  end;
  writeln('MAX: ', max);
  writeln('MIN: ', min);
  writeln('Count: ', count);
end;

begin
  for i:=0 to 14 do begin
    write('n: ');
    readln(m[i]);
  end;

  work;

  readln;
end.
0,0(0 оценок)
Ответ:
Aleksandr31821
19.02.2020 20:00

var

 n, max, count, contrl, max2: integer;

begin

 contrl := 0;

 max := 0;

 Writeln('Введите числа: ');

 Readln(n);

 while n <> 0 do

 begin

   Inc(count);

   if n>max then begin max2:=max; max:=n end

   else if n > max2 then max2 := n;

   Read(n);

 end;

 max2*=max;

 Writeln('Введите контрольное значение: ');

 Read(contrl);

 Writeln('Получено: ', count, ' чисел');

 Writeln('Получено контрольное значение: ', contrl);

 Writeln('Вычисленное контрольное значение:: ', max2);

 if contrl = max then Writeln('Контроль пройден')

 else Writeln('Контроль не пройден');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота