Sundywer
26.04.2020 01:51

Написать программу в паскале, определяющую является ли число перевертышем в паскаль. p.s перевертыш т.е с двух сторон читается одинаково, например 111

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
salautinal96
06.10.2020 22:21
// PascalABC.NET 3.3, сборка 1542 от 05.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите натуральное число: ').ToString;
  if n=ReverseString(n) then Writeln('Перевертыш')
  else Writeln('не перевертыш')
end.

Пример
Введите натуральное число:  3527253
Перевертыш

Введите натуральное число:  135233
не перевертыш
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота