mixkorabin
28.02.2022 14:13

Запишите на языке Паскаль фрагмент программы,соответствующий блок-схеме. Определите значение переменных k и t после ее выполнения

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lev93
26.08.2022 10:01
//Pascal ABC.NET Версия 2.2 Сборка 790
var s,d:string;
n,i,j:integer;
begin;
readln(n);
readln(d);
i:=1;
for j:=1 to n-1 do
i*=10;
j:=i;
while i*10<>j do
begin;
inc(j);
s:=inttostr(j);
if pos(d,s)=0 then write(s:5);
end;
end.

Пример ввода:
2
1
Пример вывода:
20   22   23   24   25   26   27   28   29   30   32   33   34   35   36   37   38   39   40   42   43   44   45   46   47   48   49   50   52   53   54   55   56   57   58   59   60   62   63   64   65   66   67   68   69   70   72   73   74   75   76   77   78   79   80   82   83   84   85   86   87   88   89   90   92   93   94   95   96   97   98   99
0,0(0 оценок)
Ответ:
RedomR
29.04.2020 10:52
Procedure TForm1.Button1Click(Sender: TObject);
var
  i1,i2,i3 : Integer;
  m : array [1..10] of Integer;
  kk : Integer;
begin
  Memo1.Clear;
  for i1 := 1 to 10 do
  begin
    m[i1]:= Random(10)-5;
    Memo1.Lines.Append('m['+inttostr(i1)+'] = '+inttostr(m[i1]));
  end;
  Memo1.Lines.Append('');
  kk := 0;
  for i1 := 1 to 10-2 do
  begin
    for i2 := i1+1 to 10-1 do
    begin
      for i3 := i2+1 to 10 do
      begin
        if ( (m[i1]+m[i2]+m[i3])=0) then
        begin
          inc(kk);
          Memo1.Lines.Append('Индекс = '+inttostr(i1)+'  '+inttostr(i2)+'  '+inttostr(i3)+'      Значение = '+inttostr(m[i1])+'  '+inttostr(m[i2])+'  '+inttostr(m[i3]));
        end;
      end;
    end;
  end;
  Memo1.Lines.Append('');
  if kk>0 then
    Memo1.Lines.Append('Да в этом массиве есть три числа сумма которых равна нулю')
  else
    Memo1.Lines.Append('Нет в этом массиве три числа сумма которых равна нулю');
  Memo1.Lines.Append('Количество комбинаций = '+inttostr(kk));
end;


Дан массив из n целых чисел а1, а2, an. вам нужно проверить, есть ли в этом массиве три числа сумма
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота