Alenka341
29.07.2021 21:43

Нужно организовать следующий вывод результата работы программы: Сумма элементов массива = ? Произведение элементов массива = ? Все нужно напечатать на одной строке. Вместо знака вопроса программа должна напечатать соответствующее значение

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Løæålø
25.11.2021 16:30
№1.
Написать программу ввода с клавиатуры и вывода на экран значений одномерного массива А, состоящего из n вещественных элементов (n=10). Найти сумму элементов этого массива и вывести ее на экран.

№2.
Используя оператор выбора, написать программу которая запрашивает у пользователя номер месяца и выводит на экран соответствующее название времени года. В случае если пользователь укажет недопустимое число, программа должна вывести сообщение “Ошибка вывода данных. Повторите ввод”.

№3.
Дан одномерный массив В из n вещественных элементов (n=10). Написать программу, которая вводит значения элементов этого массива с клавиатуры, выводит элементы массива одной строкой, находит наибольший элемент и выводит результат поиска на экран.

№4.
Задана некоторая строка S$. Дано число k и слово а$. Вставить в строку после k-ого символа слово а$, результат вывести на экран.

№5.
Составить программу, которая 100 элементов одномерного массива d заполняет квадратами первых ста целых чисел и выводит их на экран.

№6.
Ввести с клавиатуры значения n вещественных элементов массива с (n = 10), посчитать количество отрицательных и сумму положительных элементов. Результаты вывести на экран.

№7.
Написать программу, которая, используя генератор случайных величин выводит на экран пример на умножение 2-х случайных однозначных чисел, запрашивает ответ пользователя, проверяет его и выводит сообщение “ Правильно!” или “Вы ошиблись” и правильный ответ.

Ниже приведён рекомендуемый вид экрана во время работы программы:
Сколько будет 6*7 ?
Введите ответ и нажмите
-> 56
Вы ошиблись. 6*7 = 42.

№8.
Написать программу, которая используя функции mod (остаток от деления) и div (целая часть от деления) находит сумму чисел любого трехзначного числа, число вводится с клавиатуры.

№9
Написать программу подсчета количества чисел кратных 7 на отрезке от 40 до 120. Результат вывести на экран.
0
Лучшие ответы (3)
Сообщение: #664522 Сообщение: #664674 Сообщение: #668972

Копировать видео ссылку
Проиграть / Остановить
Выключить / Включить звук
Сообщить о проблеме
Язык
Mox плеер
Programming
Эксперт
94731 / 64177 / 26122
Регистрация: 12.04.2006
Сообщений: 116,782
16.04.2010, 08:15
ответы с готовыми решениями:
Составьте программу ввода с клавиатуры элементов массива а [1.10] и вывода их на экран в столбец
Составьте программу ввода с клавиатуры элементов массива а и вывода их на экран в столбец

Написать программу ввода и вывода одномерного массива и подсчитать количество чисел совпадающем с числом А
напишите мне вот это на turbo pascal Написать программу ввода и вывода одномерного...

Написать программу ввода 2 значений и вывода результата
Нужна , сколько возился не выходит. Нужно написать программу в которой будет вносится 2...

Написать программу вывода на экран таблицы значений Y: Y=X2+1 Для всех значений X от 0 до 2 с интервалом 0,25
Написать программу вывода на экран таблицы значений Y: Y=X2+1 Для всех значений X от 0 до 2 с...

17

Powered by

RAIDER_55
24 / 24 / 18
Регистрация: 04.04.2010
Сообщений: 229
16.04.2010, 08:47 2
Лучший ответ Сообщение было отмечено mik-a-el как решение
Решение
1.

PascalВыделить код
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
var
a: array[1..10] of integer;
i,sum:integer;
begin
sum:=0;
write('Enter elementi: ');
for i:=1 to 10 do
read(a[i]);
writeln;
for i:=1 to 10 do
begin
write(a[i],' ');
sum:=sum+a[i];
end;
writeln;
writeln(sum);
readln;
end.
Добавлено через 4 минуты
2.

PascalВыделить код
1
2
3
4
5
6
7
8
9
10
11
12
13
14
var
x:integer;
begin
write('Vvedite nomer: ');
readln(x);
case x of
1,2,12: writeln('Zima');
3,4,5: writeln('Vesna');
6,7,8:writeln('Leto');
9,10,11: writeln('Osen');
else writeln('Oshibka.');
end;
readln;
end.
Добавлено через 3 минуты
5.

PascalВыделить код
1
2
3
4
5
6
7
8
9
10
11
12
13
14
var
a: array[1..100] of integer;
i:integer;
begin
for i:=1 to 100 do
begin
a[i]:=i*i;
end;

for i:=1 to 100 do
write(' ', a[i]);

readln;
end.
Добавлено через 4
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота