Prostoy23
17.03.2021 04:04

Требовалось написать программу, которая определяет, лежит ли точка А(х,у) внутри некоторого кольца («внутри» понимается в строгом смысле, т.е. случай, когда точка А лежит на границе кольца, недопустим). Центр кольца находится в начале координат. Для кольца заданы внутренний и внешний радиусы r1, r2; известно, что r1 отлично от r2, но неизвестно, r1 > r2 или r2 > r1. В том случае, когда точка А лежит внутри кольца, программа должна выводить соответствующее сообщение, в противном случае никакой выходной информации не выдается. Программист сделал в программе ошибки.
var x, у, rl,r2:real;
h: real;
begin
readln (x, у, rl, r2);
h := sqrt (x*x + y*y);
if (h < rl) AND (h > r2) then
writeln ('точка А лежит внутри кольца');
end.
Последовательно выполните задания:
1. Приведите пример таких чисел х и у, при которых программа неверно решает поставленную задачу.
2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы. (Это можно сделать несколькими поэтому можно указать любой доработки исходной программы).
3. Укажите, как можно доработать программу, чтобы она не содержала логических операций AND или OR.
Примечание: для обозначения расстояния от точки А до начала координат используется вс переменная h.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
surikat235
30.05.2020 05:15

избежать ошибок во время проектирования

Разработка нового оборудования — процесс трудоемкий и затратный. Недочеты, которые закрались на этом этапе, могут дорого обойтись, а на их устранение понадобится много времени.

Дополненная реальность экономит средства и ресурсы за счет работы с виртуальными прототипами будущей модели. С планшетов или через специальные очки специалисты видят чертежи как объемные проекции. Можно даже устроить виртуальный тест конструкции. Это оценить эргономику продукта и обнаружить недочеты, которые не видны на этапе проектирования.

Эксперты из «Корус консалтинг», анализируя данные рынка, в 2017 году назвали основные сферы применения AR в промышленности. Технология будет наиболее востребована в авиа-, судо-, автомобилестроении и промышленном строительстве.

В работе «Эффективность дополненной реальности в обрабатывающей промышленности» эстонские исследователи приходят к выводу, что использование AR на этапах проектирования приведет к существенному сокращению возможных ошибок. Австрийский производитель мотоциклов KTM на собственном опыте убедился, что если использовать AR в проектировании, время выхода новой модели на рынок сократится на 15%.

0,0(0 оценок)
Ответ:
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Матрица А ***');
  var a:=MatrRandom(4,7,-50,50); a.Println(4);
  Writeln('*** Матрица B ***');
  var b:=MatrRandom(4,7,-50,50); b.Println(4);
  Writeln(4*a.ColCount*'-');
  Writeln('*** Матрица А-B ***');
  for var i:=0 to 3 do begin
    for var j:=0 to 6 do Write(a[i,j]-b[i,j]:4);
    Writeln
    end;
end.

Пример
*** Матрица А ***
  11 -12 -37  22   3  -8  16
  -2  21  31   4  -1  13  20
  18 -42 -46 -17  19   8 -14
 -26 -32  -2  31 -26 -43 -31
*** Матрица B ***
  13 -14  12 -37   2 -12  34
  26  25 -47   2 -42   1 -43
  44  -6  -1  24  37  -9  -3
 -30   3 -29 -39 -11  -8 -14

*** Матрица А-B ***
  -2   2 -49  59   1   4 -18
 -28  -4  78   2  41  12  63
 -26 -36 -45 -41 -18  17 -11
   4 -35  27  70 -15 -35 -17
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота