Напишите программу, которая определяет самые секретные секреты Мэри Поппинс. Во введенной строке много раз повторяются слова Мэри Поппинс, а между ними написаны ее секреты. Нужно найти только те, в которых есть пробелы. И вывести через точку и пробел.

Формат ввода
Вводится строка.

Формат вывода
Вывести в строку через точку и пробел все секреты Мэри Поппинс, в которых есть пробелы.

Пример 1
Ввод Вывод
ее принес восточный ветер Мэри Поппинс няня Мэри Поппинс здоровое питание Мэри Поппинс ковровая сумка Мэри Поппинс улыбка
ее принес восточный ветер. здоровое питание. ковровая сумка
Пример 2
Ввод Вывод(пусто)
Леди Мэри Поппинс няня

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ларисаяна
03.05.2020 11:38
// Задание 1
const
  n = 100;

var
  a: array[1..n] of integer;
  i, s: integer;

begin
  for i := 1 to 15 do
  begin
    write('a[', i, '] = ');readln(a[i]);
    if i mod 3 = 0 then s := s + a[i];
  end;
  writeln('Сумма элементов, индексы которых кратны 3 = ', s);
end.

Тестовое решение:
число элементов : 10
a[1] = 2
a[2] = 5
a[3] = 1
a[4] = 5
a[5] = 6
a[6] = 3
a[7] = 5
a[8] = 6
a[9] = 1
a[10] = 8
Сумма элементов, индексы которых кратны 3 = 5

// Задание 2
const
  n = 100;

var
  a: array[1..n] of integer;
  i: integer;

begin
  for i := 1 to 15 do
  begin
    a[i] := random(100);write(a[i]:4);
  end;
  writeln;
  for i := 1 to 15 do
  begin
    if i mod 2 = 0 then a[i] := a[i] * 2;
    write(a[i]:4);
  end;
end.

Тестовое решение:
  35  98  67  94  63  18  26  17   3   5   0  77  47  11  33
  35 196  67 188  63  36  26  34   3  10   0 154  47  22  33

// Задание 3
const
  m = 100;

var
  a: array[1..m] of integer;
  i, n, k, tmp: integer;

begin
  write('число элементов : ');
  readln(n);
  for i := 1 to n do
  begin
    write('a[', i, '] = ');readln(a[i]);
  end;
  repeat
    write('Введите к (k<>1 и k<>n)');
    readln(k);
    if (k = 1) or (k = n) then writeln('Ошибка, повторите ввод');
  until (k <> 1) and (k <> n);
  for i := 1 to n do write(a[i]:4);writeln;
  tmp := a[k - 1];a[k - 1] := a[k + 1];a[k + 1] := tmp;
  for i := 1 to n do write(a[i]:4);
end.

Тестовое решение:
число элементов : 6
a[1] = 2
a[2] = 7
a[3] = 3
a[4] = 8
a[5] = 9
a[6] = 1
Введите к (k<>1 и k<>n)4
   2   7   3   8   9   1
   2   7   9   8   3   1
0,0(0 оценок)
Ответ:
артем1ппн
12.08.2021 09:14
Эту задачу уже решали здесь. Но, если трудно поискать, то вот программа:
var a,b,c,d,x,y,z,y1,z1,y2,z2,nod:integer;
begin
writeln('1-я дробь (числитель и знаменатель):');
readln(a,b);
writeln('2-я дробь (числитель и знаменатель):');
readln(c,d);
y1:=a*d+c*b; y2:=y1;
z1:=b*d; z2:=z1;
while (y2>0)and(z2>0) do
 if y2>z2 then y2:=y2 mod z2 else z2:=z2 mod y2;
nod:=y2+z2;
y1:=y1 div nod; 
z:=z1 div nod;
x:=y1 div z;
y:=y1 mod z;
if x>0 then writeln(x,' ',y,'/',z) else writeln(y,'/',z);
end.

Пример:
1-я дробь (числитель и знаменатель):
3 4
2-я дробь (числитель и знаменатель):
5 6
1 7/12
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота