Viktyfox17
25.09.2020 09:39

Решите задачи на Паскале: 1) Из введенной последовательсти чисел, найдите количество чисел, кратных 3. 2) Из введенной последовательности чисел, найдите трёхзначные числа. 3)Написать программу для подсчета суммы квадратов чисел от 1 до 10.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sa66
06.08.2020 18:16

PascalABC.NET 3.5.1 + .NET Framework 4.7.1

#1

begin

 var A := ReadSeqInteger('enter seqeunce: ',ReadInteger('seq length: '));

 A.Where(p -> p mod 3 = 0).Count.Println;

end.

#2

begin

 var A := ReadSeqInteger('enter seqeunce: ',ReadInteger('seq length: '));

 A.Where(p -> (p>=100) and (p <= 999)).ToList.Println;

end.

#3

begin

 Range(1,10).Select(p -> p * p).sum.Println;

end.

Объяснение:

0,0(0 оценок)
Ответ:
Svetik15102011
06.08.2020 18:16

var n,a,b,c: integer;

begin;

read(n);//количество чисел в последовательности

for a:=1 to n do begin

 read(b);

 if (b mod 3)=0 then c:=c+1;

 end;

 write (c);

end.

var n,a,b,c: integer;

begin;

read(n);//количество чисел в последовательности

for a:=1 to n do begin

 read(b);

 if (b div 100)>0 then c:=c+1;

 end;

 write (c);

end.

var n,a,b,c: integer;

begin;

for a:=1 to 10 do begin

c:=c+(a*a);

 end;

 write (c);

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота