anastasiyanast29
29.10.2022 12:18

Напишите программу на языке Pascal. Дано натуральное число A, в записи которого нет нулей. Требуется найти минимальное двузначное число, которое можно увидеть в записи числа A. Например, для числа 815943 ответом будет 15.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kuzyana
12.10.2020 17:03

===Pascal ABC.Net===

program ;

var

 number, min, temp :integer;

begin

 min := 100;

 Write('Введите число без нулей: ');

 ReadLn(number);

 while number <> 0 do

 begin

   temp := number mod 100;

   if (temp < min) and (temp div 10 <> 0) then min := temp;

   number := number div 10;

 end;

 Write('Минимальное двузначное число: ', min);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота