frostdog0609
23.08.2021 10:42

На pascal нужно написать программу простую, , !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
умница06092006
13.08.2022 06:11

#include <iostream>

using namespace std;

int main()

{

int N, max, min;

std::cin >> N;

int* mass = new int[N];

for (int r = 0; r < N; r++)

{

cin >> mass[r];

}

max = mass[0];

min = mass[0];

for (int r = 1; r < N; r++)

{

if (max < mass[r]) max = mass[r];

if (min > mass[r]) min = mass[r];

}

for (int r = 0; r < N; r++)

{

if (mass[r] != max and mass[r] != min)

{

cout << mass[r] << " ";

}

}

return 0;

}

Объяснение для гения на редакторе:

Я в комментариях для кого оставил поправку? C++ язык

0,0(0 оценок)
Ответ:
Kr1c
28.02.2020 22:25

           int[] array = new int[25]; // одномерный массив из 25 элементов.

           var rnd = new Random(); // новый метод System.Random .

           var count = 0; // число, определяющее кол-во кратных 2, но не кратных 3 чисел.

           for(int i = 0; i < array.Count(); i++)

           {

               int next = rnd.Next(0, 100); // рандомное число от 0 до 100 включительно.

               array[i] = next; // добавление в массив от первой переменной 25 значений.

               if(next % 2 == 0 && next % 3 != 0) // проверка на кратность 2, но не кратность 3.

               {

                   count++; // увеличение количества кратных на 2, но не кратных 3 элементов.

                   Console.WriteLine($"Число кратное 2, но не кратное 3: {next}.");

               }

           }

           Console.WriteLine($"Всего элементов кратных 2, но не кратных 3: {count}.");

           Console.ReadLine();


Язык C# Создайте приложение, которое выводит на экран значения одномерного массива из 25 элементов (
Язык C# Создайте приложение, которое выводит на экран значения одномерного массива из 25 элементов (
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота