Kotik20052005
09.01.2020 18:03

Напишите программу, которая сортирует массив из n элементов по возрастанию и считает при этом количество произведённых перестановок
(нужно в паскале)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
goodwar40
13.11.2022 18:40

import tkinter as tk  

class Form(tk.Frame):

   def __init__(self, root):

       super().__init__(root)

       root.title('graphics')

       root.resizable(False, False)

       root.geometry('640x480')

       self.pack()

       self.master = root

       self.build()

       root.mainloop()

       

   def build(self):

       

       tk.Button(text = 'small', command = lambda:self.master.geometry('320x240')).place(x = 10, y =10)

       tk.Button(text = 'medium', command = lambda: self.master.geometry('640x480')).place(x = 10, y =40)

       tk.Button(text = 'large', command = lambda: self.master.geometry('1280x720')).place(x=10,y=70)

Form(tk.Tk())

Использована встроенная библиотека tkinter

0,0(0 оценок)
Ответ:
nina19862
08.11.2022 15:46
Const n=10; 
var a:array[1..n] of integer;
i,s,min:integer;
begin
writeln('Исходный массив:');
for i:=1 to n do
 begin
 a[i]:=random(21)-10;
 write(a[i]:4);
 end;
writeln;
s:=0; 
min:=a[1];
for i:=1 to n do
 begin
 if a[i]>0 then s:=s+a[i];
 if a[i]<min then min:=a[i];
 end;
writeln('s = ',s,'   min = ',min);
for i:=1 to n do
 if a[i]>0 then a[i]:=s
  else if a[i]<0 then a[i]:=a[i]-min;
writeln('Измененный массив:');
for i:=1 to n do  write(a[i]:4);
writeln;
end.

Пример:
Исходный массив:
   9  -3  -5   7   1   5  -6   9  -8   7
s = 38   min = -8
Измененный массив:
  38   5   3  38  38  38   2  38   0  38
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота