LOKI46
08.11.2021 21:17

Написать программу поиска минимального значения в массиве, вывести на экран минимальное значение и номер (индекс) этого значения.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
emmiemgrowen2356
20.08.2020 23:43
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  var i:=a.IndexMin;
  Writeln('Минимальный элемент ',a[i],' имеет индекс ',i+1)
end.

Пример
n= 15
66 -91 75 27 7 -95 96 48 -35 77 49 71 -13 25 -8
Минимальный элемент -95 имеет индекс 6
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота