kudinovakarina27
28.09.2022 01:25

37 ! составить программу на pascal.

условие: даны три стороны треугольника. вычислите площадь и периметр.
ход решения: ввести три цифры - стороны треугольника и с форум нахождения площади и периметра треугольника найти их.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
олжас200
10.10.2020 21:14

var a,b,c,p,s: real;

begin

 write('Введите 1-ю сторону: '); readln(a);

 write('Введите 2-ю сторону: '); readln(b);

 write('Введите 3-ю сторону: '); readln(c);

 p:= a + b + c;

 s:=sqrt((p/2)*(p/2-a)*(p/2-b)*(p/2-c));

 writeln('Периметр = ', p);

 writeln('Площадь = ', s);

end.

0,0(0 оценок)
Ответ:
MillaGuper
10.10.2020 21:14

===== PascalABC.NET =====

begin

 var (a, b, c) := ReadReal3('Введите длины сторон через пробел:');

 var P := a + b + c;

 var p2 := P / 2;  // полупериметр

 var S := Sqrt(p2 * (p2 - a) * (p2 - b) * (p2 - c)); // ф-ла Герона

 Println('P =', P, '   S =', S)

end.


37 ! составить программу на pascal. условие: даны три стороны треугольника. вычислите площадь и пери
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота