Нужно составить программу на c++ кто сможет скиньте код
дано: x=1; dx=0.5. z вычислять по формуле: , где . считать z до тех пор, пока y > 0.02. определить k - количество вычисленных z. вывести на экран x, y, z, k.
var x, n: integer; n1: real; begin Writeln('Введите число: '); Read(x); if (x > 9) and (x < 100) then begin n := (x div 10) + (x mod 10); Writeln('Сумма цифр равна: ', n); end; if (x > 99) and (x < 1000) then begin n := (x div 100) * ((x div 10) mod 10) * (x mod 10); Writeln('Произведение цифр равно: ', n); end; if (x > 999) and (x < 10000) then begin n := x div 1000 + (x div 100) mod 10 + (x div 10) mod 10 + x mod 10; n1 := n / 4; Writeln('Среднее арифметическое равно: ', n1); end; if x > 9999 then begin Writeln('Введите 2-х, 3-х или 4-х значное число'); end; end.
Var M: array[1..32767] of real; Min: real; N, i: integer; Begin Write('N = ');ReadLn(N); if (N <= 0) then WriteLn('Количество элементов должно быть положительно') else begin Write('Введите элементы массива в количестве ',N,' штук'); For i:= 1 to N do Read(M[i]); Min := M[1]; For i:= 2 to N do if (M[i] < Min) then Min := M[i]; WriteLn; Write('Получившийся массив:'); For i:= 1 to N do begin M[i] := M[i] / Min; Write(' ',M[i]); end; end End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку