Чай22
16.12.2021 20:29

Умоляю ,
составьте программы на паскале для решения :
1. напишите на ая алгоритм сложения двух простых дробей ( без сокращения дроби)
2. напишите на ая алгоритм вычисления y по формуле y=(1-x^2+5x^4)^2 , где x - заданное целое число
3. напишите наиболее короткие алгоритмы вычисления выражения y=x^10

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Валерияжеле
10.10.2020 06:18

Задание 1)

Program Task_1;

 

var

a, b, c, d: integer;

 

begin

 

writeln('Напишите значение числителя первой дроби:');

readln(a);

 writeln('Напишите значение знаменателя первой дроби:');

 readln(b);

   

  writeln('Напишите значение числителя второй дроби:');

  readln(c);

   writeln('Напишите значение знаменателя второй дроби:');

   readln(d);

   

    writeln('Сложение двух данных дробей равно: ', (a/b)+(c/d));

     

end.

Задание 2)

Program Task_2;

 

var

x,y: integer;

 

begin

 

writeln('Введите значение переменной x:');

readln(x);

 

 writeln('y=(1-x^2+5x^4)^2, y = ', sqr(1-x*x+5*sqr(x*x)));

 

 

end.

Задание 3)

Program Task_3;

 

var

x,y: real;

 

begin

 

writeln('Введите значение переменной x:');

readln(x);

 y:= x*x*x*x*x*x*x*x*x*x;

   

   y:= exp(ln(x)*10);

     

     

    end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота