alenaizmailova
14.08.2022 01:33

Много .
4
на кружке по программированию учи
программированию учитель задал васе на обработку
последовательности чисел по следующему алгоритму.
1. дописать зеркальную копию последе
алгоритма в конец последовательности
2. поместить когiию последователь
начало последовательности
3. прибавить 1 ко всем числам в пос.
шаге.
4. в середину полученной
зную копию последовательности чисел полученной на вход
ию последовательности чисел полученной после первого шага в
тко всем числам в последовательности, полученной на предыдущем
пну полученной на предыдущем шаге последовательности коместь
последовательность чисел, полученную на вход алгоритма.
учитель предложил васс один раз п
пос
n
редложил вас один раз применить алгоритм, взяв в качестве входной
ледовательности два числа о 1». вася выполнил алгоритм, записывая результаты
каждого шага:
2 1 1 2
21 122 112
32 233223
322 321 322 3
учитель сказал, что вася получил верный результат и предложил ему выполнить весь
алгоритм еще несколько раз, считая, что при каждом новом выполнении алгоритма ему на
вход подается последовательность, получившаяся в результате предыдущего выполнения
алгоритма. то есть, при втором выполнении алгоритма ему на вход буде подана
последовательность «3 2 2 3 2 1 3 2 2 3», которую вася получил в результате первого
выполнения алгоритма.
определите, сколько раз вася повторил алгоритм, если оказалось, что в
получившейся у него последовательности на 15625-й и 15626-й позициях, считая слева
направо от начала этой последовательности, стоят числа «2» и «», соответственно.
в ответе укажите число, соответствующее количеству повторений алгоритма,
включая первое применение алгоритма, указанное в примере.
​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
NastysikRicci
16.01.2023 02:24
Uses  crt;const  nmax=100;var  a1,a2: array[1..nmax] of integer;  n,i,b,k,s: integer;begin  randomize;  clrscr;  repeat    write('Введите размер массива n (n in [1..',nmax,']): ');    readln(n);    write('Введите число B (0<B<100): ');    readln(b);  until (n in [1..nmax]) and (b in [1..99]);  writeln('Массив A1');  for i:=1 to n do  begin    a1[i]:=random(99);    write(a1[i]:4);    if a1[i]>b then    begin      inc(k);      a2[k]:=i;      s:=s+a1[i];    end;  end;  writeln;  writeln('Среднее элеметов, больших B = ',s/k:0:2);  writeln('Массив A2:');  for i:=1 to k do write(a2[i]:4);  readln;end.
0,0(0 оценок)
Ответ:
dimas1410
16.01.2023 02:24

program number1;

var a: array [1..5] of integer;

i,min,max: integer;

Begin

writeln('Введите 5 значений массива');

for i:=1 to 5 do

readln(a[i]);

min:=a[1];

max:=a[1];

for i:=1 to 5 do

Begin

if (a[i]>=max) then max:=a[i];

if (a[i]<=min) then min:=a[i];

End;

for i:=1 to 5 do

Begin

if max=a[i] then

Begin

 writeln('Максимальное значение: ',a[i],' [',i,']');

 max:=a[i];

End;

if min=a[i] then  

 Begin

 writeln('Минимальное значение: ',a[i],' [',i,']');

 min:=a[i];

 End;

End;

writeln('Среднее арифметическое: ',(min+max)/2);

End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота