bsvetlana760
25.12.2022 20:17

Надо написать программу на языке паскаль. первую я поняла и решила, а все остальные чет не могу понять (насчет 3 есть мысли, но все равно не доходит)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sawensia
23.03.2022 22:17
Компьютерный вирус это специально написанная не большая по размерам программа, которая может приписывать себя к другим программам то есть 
заражать их, а также выполнять нежелательные действия на компьютере.
программа внутри которой находится вирус называется зараженной. когда такая программа находит работу то сначала управления получает  вирус.
вирус находит и заражает другие программы, а также выполняет вредные действия. например: портит файлы или таблицу размещения файлов на диске а также засоряет оперативную память. 
0,0(0 оценок)
Ответ:
tayakovalenko
07.08.2020 14:04
А) Решение не совсем эффективно, но для школьного примера, то что нужно.
#include <iostream>
using namespace std;

unsigned fib(unsigned x)
{
    if (x == 0)
        return 0;
    if (x == 1 || x == 2)
        return 1;
    else if(x > 2)
        return fib(x - 1) + fib(x - 2);
}

int main()
{
    unsigned n = 0;
    cout << "How much numbers you want to print: " << endl;
    cin >> n;
    cout << "The Finonacci serie: " << endl;
    for(unsigned i = 0; i < n; ++i) {
      cout << fib(i) << " ";
    }
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота