Anastasia987654321
18.01.2021 12:05

Составьте программу для удаления первых 2 символов в введенной строке ( строку вводит пользователь )​ . паскаль, 9 класс.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
katrin20005
10.05.2020 06:21

Если будете сдавать в тестирующей системе, то вместо string, лучше использовать массив char - работает быстрее.

var n,i,k,p,mx,mxj: integer;

   s: array[1..100000] of char;

begin

 readln(n);

 for i:=1 to n do read(s[i]);

 k:=0; p:=0;

 mx:=0; mxj:=0;

 for i:=1 to n do

 begin

   if s[i]='G' then k:=k+1

   else

   begin

     if p=1 then

     begin

       p:=0;

       if s[i-1]='G' then  

       if (k>mxj) then mxj:=k;

       k:=0;

     end

     else

     begin

       if k>0 then p:=1;

       if k>mx then mx:=k;

     end;

   end;  

 end;

 if mx>mxj then k:=mx+1

 else k:=mxj+1;

 if k=1 then k:=0;

 writeln(k);

end.

0,0(0 оценок)
Ответ:
Malifisen
10.05.2020 06:21

Объяснение:

Вы можете уменьшить размер файлов и сэкономить пространство на диске с сжатия рисунков в документе. Параметры сжатия уменьшают как размер файл, так и размеры рисунков, в зависимости от того, как планируется использовать изображение, например для просмотра на экране или в сообщении электронной почты. Сжать можно все рисунки в файле или только специально выделенные.

Если документ сохранен в более старом формате DOC, то параметр "Уменьшить размер файла" не будет доступен в меню "Файл". Чтобы использовать параметр "Уменьшить размер файла", сохраните документ в новом формате DOCX.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота