AlexeyB96
04.08.2022 07:07

Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. (язык pascal)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
anyasuharevap0ai22
08.10.2020 09:36
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),1,200); a.Println;
  Writeln('Ср.арифметическое кратных 3: ',
      a.Where(t->t mod 3=0).DefaultIfEmpty.Average)
end.

Пример
n= 15
185 103 5 33 116 167 189 36 79 110 188 12 26 11 10
Ср.арифметическое кратных 3: 67.5
0,0(0 оценок)
Ответ:
vipmopmop
08.10.2020 09:36
Если всё-таки нужно среднее арифметическое всех чисел, кратных 3, в диапазоне от 1 до 200

var i,s,k:integer;
begin
for i:=1 to 200 do
if i mod 3 = 0 then begin
s:=s+i;
k:=k+1
end;
writeln ('Среднее арифметическое чисел, кратных 3, в диапазоне от 1 до 200 равно: ',s/k)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота