мари420
29.06.2021 17:56

Составить программу для pascalabc: статья, набранная на компьютере, содержит х страниц, на каждой странице y строк, в каждой строке z символов. определите информационный объём статьи в битах, байтах и килобайтах,если каждый символ кодируется 8 битами.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bgf62
06.06.2020 10:25
Const n = 5;
  m = 5;
var a:array[1..n,1..m] of integer;
i,j,s:integer;
begin
//Для теста заполним массив сл.числами
  for i:=1 to n do begin
    for j:=1 to m do begin
      a[i,j]:=random(21)-10; write(a[i,j]:4);
    end;
    writeln;writeln;
  end;
  //сумма всех элементов массива
  for i:=1 to n do
    for j:=1 to m do s:=s+a[i,j];
writeln('сумма всех элементов массива: ',s);
//сумма каждой строки
for i:=1 to n do begin
    s:=0;
    for j:=1 to m do begin
      s:=s+a[i,j];
    end;
    writeln ('Строка: ',i,' сумма:',s);
  end;   
end.
0,0(0 оценок)
Ответ:
lubvic77
09.07.2021 07:31
Если считать отрицательные трехзначные, то сумма таких чисел в диапазонах от -999 до -100 и от 100 до 999 будет равна 0. Для только положительных:

//c циклом for
var s,i:integer;
begin
  for i:=100 to 999 do
    if i mod 77 = 0 then s:=s+i;
  writeln('Сумма трехзначных кратных 77: ',s);
end.

Тестовое решение:
Сумма трехзначных кратных 77: 5929

// с циклом while
var s,i:integer;
begin
  i:=100;
  while i<=999 do begin
    if i mod 77 = 0 then s:=s+i;
    i:=i+1;
  end;
  writeln('Сумма трехзначных кратных 77: ',s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота